ShippingEasy Performance
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Nov 29, 2022 - 14:19 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2022 - 13:32 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2022 - 11:49 CST
Investigating
ShippingEasy is aware of the current performance issues impacting ShippingEasy. We are actively investigating this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Nov 29, 2022 - 11:18 CST
This incident affected: ShippingEasy (app.shippingeasy.com).