Support Service

Incident Report for ShippingEasy

Resolved

Thank you for your patience while our integrators worked to resolve your issues with our Chat support widget.
Posted Mar 24, 2025 - 08:11 CDT

Update

We are continuing to investigate this issue.
Posted Mar 21, 2025 - 16:52 CDT

Investigating

ShippingEasy is aware of the technical issues impacting ShippingEasy Support's Messaging service. We are actively working with Zendesk to resolve this issue and will provide updates as they become available to us.
Posted Mar 21, 2025 - 15:02 CDT
This incident affected: Support Services (Chat Support).