Canadian Disruption Updates

Incident Report for ShippingEasy

Update

We are continuing to investigate this issue.
Posted May 23, 2025 - 11:52 CDT

Update

We are continuing to investigate this issue.
Posted May 23, 2025 - 11:51 CDT

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 15:35 CDT

Update

We are continuing to investigate this issue.
Posted May 16, 2025 - 10:59 CDT

Investigating

Effective Friday, May 23, 2025, Canada Post continues to operate with CUPW banning overtime work. Customers may experience delays. At this time, there are NO rotating strikes or national work stoppages.
Learn more: www.canadapost-postescanada.ca

U.S. Carrier Update

Effective Friday, May 23, 2025, GlobalPost Economy International and Standard International services to Canada are back to normal operations and available.

Effective Sunday, May 18, 2025, UPS will implement a Surge Fee for Air and Ground for UPS shipments as follows: UPS Standard® to Canada: $0.49 USD /pkg, All Other Services to Canada: $0.49 USD/per pound.
Posted May 15, 2025 - 17:47 CDT
This incident affects: Carriers (UPS).