USPS suspending shipments to Canada
Incident Report for ShippingEasy
Update
We are continuing to monitor for any further issues.
Posted Dec 20, 2024 - 13:24 CST
Update
Please see below for the latest updates as of December 20, 2024
Posted Dec 20, 2024 - 13:21 CST
Update
We are continuing to monitor for any further issues.
Posted Dec 11, 2024 - 16:28 CST
Update
We are continuing to monitor for any further issues.
Posted Nov 27, 2024 - 21:47 CST
Monitoring
Update as of 12/20/2024: USPS has not yet resumed mail or package delivery to Canada for any mail class following the recent Canadian Union of Postal Workers strike. We’ll keep you informed as we receive updates. In the meantime, please continue to use an alternate carrier.

This service disruption affects Priority Mail Express International® (PMEI), Priority Mail International® (PMI), First-Class Mail International® (FCMI), First-Class Package International Service® (FCPIS), International Priority Airmail® (IPA), International Surface Air Lift® (ISAL), Commercial ePacket® (CeP), and M-Bag® items.

GlobalPost: Effective, December 6, 2024, GlobalPost is temporarily unable to deliver to certain postal codes in Canada due to the CUPW strike, as GlobalPost's network relies on Canada Post for delivery to these destinations. Please reach out to our support teams for the list of impacted postal codes. GlobalPost continues to deliver shipments to Canada, excluding these specific destinations.
Posted Nov 27, 2024 - 17:12 CST
This incident affects: Carriers (USPS, Stamps.com, Endicia).