Integration Issues

Incident Report for ShippingEasy

Resolved

Thank you for your patience while ShippingEasy Engineers worked to resolve issues with our Chat widget.

Please refresh your browser in order to reflect the changes made.
Posted Mar 13, 2025 - 12:08 CDT

Investigating

ShippingEasy Engineers are aware of the technical issues impacting our chat widget. We are actively working to resolve this issue and will provide updates as they become available to us.

In the meantime, you can reach us by phone or by emailing help@shippingeasy.com

Thank you for your patience!
Posted Mar 13, 2025 - 10:14 CDT
This incident affected: Support Services (Chat Support).