Errors on postage purchase for stamps.com
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 15:30 CDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers’ ability to purchase postage. Updates will be available from the stamps.com status page at https://status.stamps.com/
Posted Jul 07, 2020 - 15:02 CDT
This incident affected: Carriers (Stamps.com).