Site Slowness

Incident Report for ShippingEasy

Resolved

This incident has been resolved.
Posted Nov 06, 2023 - 08:28 CST

Update

We are continuing to investigate this issue.
Posted Nov 04, 2023 - 13:31 CDT

Investigating

ShippingEasy is currently experiencing performance-related issues that may be causing slowness for merchants. We are aware of the impact this has on you, and we are working to identify the issue! We thank you for your patience!
Posted Nov 03, 2023 - 13:38 CDT
This incident affected: ShippingEasy (app.shippingeasy.com, shippingeasy.com).