Slowness
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 09:27 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 02, 2023 - 18:04 CDT
Update
We are continuing to investigate this issue.
Posted Nov 02, 2023 - 15:20 CDT
Investigating
ShippingEasy is currently experiencing performance-related issues that may be causing slowness for merchants. We are aware of the impact this has on you, and we are working to identify the issue! Thank you for your patience!
Posted Nov 02, 2023 - 15:18 CDT
This incident affected: ShippingEasy (app.shippingeasy.com, shippingeasy.com).