UPS outage

Incident Report for ShippingEasy

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 15:11 CST

Investigating

ShippingEasy is currently experiencing issues with UPS that are impacting our label generation. We are aware of the impact this has on you, and we are working to identify the issue!
Posted Nov 29, 2023 - 12:22 CST