Carrier Issues
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 17:04 CDT
Investigating
ShippingEasy is aware of the technical issues impacting integrated carriers. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Oct 22, 2021 - 12:23 CDT
This incident affected: Carriers (FedEx).