Stamps.com - Issue Creating Label
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 11:14 CST
Update
We’re experiencing an elevated level of errors with Stamps.com and are currently looking into the issue.
Posted Nov 30, 2020 - 10:36 CST
Investigating
We are currently investigating this issue.
Posted Nov 30, 2020 - 10:35 CST
This incident affected: Carriers (USPS, Stamps.com, Endicia, UPS, FedEx, Globalpost, DHL Express, Amazon Buy Shipping), ShippingEasy (app.shippingeasy.com, shippingeasy.com), Marketplaces (Amazon US, Shopify, LuLaRoe BLESS, Walmart, eBay, WooCommerce, Etsy, Magento 2), Support Services (Chat Support, Phone Support), Integrations (Shipsurance), and Add-ons (Customer Marketing, Inventory).