Support Service

Incident Report for ShippingEasy

Resolved

Thank you for your patience while our teams worked to resolve our support issues.
Posted Nov 20, 2025 - 09:00 CST

Investigating

ShippingEasy Support is aware of the technical issues impacting our support phone lines and chat connections. We are actively monitoring the status of these issues and will provide updates as they become available to us.

Thank you for your patience!
Posted Nov 19, 2025 - 08:41 CST
This incident affected: Support Services (Chat Support, Phone Support).