Carrier Issues
Incident Report for ShippingEasy
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Please refresh your browser to reflect the changes made.
Posted Nov 05, 2021 - 14:10 CDT
Investigating
ShippingEasy is aware of the technical issues impacting integrated carriers. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Nov 05, 2021 - 11:50 CDT
This incident affected: Carriers (FedEx).