DHL Express Canada Updates

Incident Report for ShippingEasy

Update

Effective Monday, June 30th, DHL Express has restored all services in Canada to normal operations.
Posted Jun 30, 2025 - 16:33 CDT

Monitoring

Effective Monday, June 30th, DHL Express has restored all services in Canada to normal operations.
Posted Jun 16, 2025 - 18:48 CDT
This incident affects: Carriers (DHL Express).