USPS International error: Invalid Rate

Incident Report for ShippingEasy

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 11:29 CDT

Monitoring

We are investigating an issue getting a rate quote for USPS international shipments.
Posted Jul 13, 2026 - 08:55 CDT
This incident affected: Carriers (USPS).