ShippingEasy
Incident Report for ShippingEasy
Resolved
The issues with the ShippingEasy app have been resolved by Amazon. Please visit https://status.aws.amazon.com/ for any further updates.
Posted Dec 15, 2021 - 10:34 CST
Investigating
ShippingEasy is aware of Amazon Web Services issues impacting the ShippingEasy app. We are actively monitoring this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Dec 15, 2021 - 09:35 CST
This incident affected: ShippingEasy (app.shippingeasy.com).