Increased Latency

Incident Report for ShippingEasy

Resolved

This incident has been resolved.
Posted Mar 08, 2024 - 13:16 CST

Update

We are continuing to investigate this issue.
Posted Mar 08, 2024 - 13:16 CST

Investigating

We are investigating reports of higher than expected latency when getting rates.
Posted Mar 08, 2024 - 13:00 CST
This incident affected: ShippingEasy (app.shippingeasy.com, shippingeasy.com).