Marketplace Issues
Incident Report for ShippingEasy
Resolved
Thank you for your patience while our partners worked to resolve your issue.

All merchant should be able to download and process Amazon shipments.

Please refresh your browser to reflect any changes. If you still need assistance, please reach out to our Support team and we will be happy to further investigate.

Thank you.
Posted Dec 07, 2022 - 22:15 CST
Monitoring
We are aware of an incident being reported by Amazon that may be impacting order downloads into ShippingEasy. We are continuing to monitor the situation will provide updates as they become available. You can monitor the status of that incident here: http://status.mws.amazon.com/
Posted Dec 07, 2022 - 17:00 CST
Investigating
We are aware of an incident being reported by Amazon that may be impacting order downloads into ShippingEasy and are actively investigating. You can monitor the status of that incident here: http://status.mws.amazon.com/ and we will provide updates as they become available.
Posted Dec 07, 2022 - 08:29 CST
This incident affected: Marketplaces (Amazon US).