Stamps Issue Creating Labels

Incident Report for ShippingEasy

Resolved

This incident has been resolved.
Posted Sep 24, 2021 - 16:46 CDT

Update

We are continuing to investigate this issue.
Posted Sep 24, 2021 - 15:35 CDT

Update

We are continuing to investigate this issue.
Posted Sep 24, 2021 - 15:34 CDT

Investigating

ShippingEasy is aware of the technical issues impacting Stamps.com and partnered carriers. We are actively monitoring the status of these issues and will provide updates as they become available.

Thank you for your patience!
Posted Sep 24, 2021 - 14:30 CDT
This incident affected: Carriers (USPS, Stamps.com).