Lularoe Bless Outage
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 10:33 CDT
Investigating
ShippingEasy is aware of the technical issues impacting Lularoe Bless. We are actively monitoring the status of these issues and will provide updates as they become available
Posted Sep 18, 2024 - 09:28 CDT