Integration Issues
Incident Report for ShippingEasy
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Posted Apr 22, 2024 - 11:35 CDT
Investigating
ShippingEasy is aware of the technical issues impacting inbound phone calls. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Apr 22, 2024 - 10:30 CDT
This incident affected: Support Services (Phone Support).