FedEx Label Creation

Incident Report for ShippingEasy

Resolved

This incident has been resolved.
Posted Jul 21, 2021 - 14:54 CDT

Update

We are continuing to monitor for any further issues.
Posted Jul 21, 2021 - 13:52 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 13:52 CDT
This incident affected: Carriers (FedEx).