Shipsurance Issues
Incident Report for ShippingEasy
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Please refresh your browser to reflect the changes made.
Posted Jun 07, 2022 - 17:06 CDT
Update
We are continuing to investigate this issue.
Posted Jun 07, 2022 - 14:36 CDT
Investigating
ShippingEasy is aware of the technical issues impacting Shipsurance. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Jun 07, 2022 - 14:26 CDT
This incident affected: Integrations (Shipsurance).