ShippingEasy
Incident Report for ShippingEasy
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Please refresh your browser to reflect the changes made.
Posted Aug 31, 2021 - 18:48 CDT
Investigating
ShippingEasy is aware of the technical issues impacting ShippingEasy. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Aug 31, 2021 - 15:27 CDT
This incident affected: ShippingEasy (app.shippingeasy.com).