ShippingEasy Order & Carrier Rate Errors
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 12:23 CDT
Investigating
ShippingEasy is aware of the technical issues impacting the ShippingEasy Platform. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Sep 13, 2024 - 11:50 CDT
This incident affected: ShippingEasy (app.shippingeasy.com, shippingeasy.com).