Carrier Issues - UPS
Incident Report for ShippingEasy
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 10:34 CDT
Update
UPS has confirmed they are experiencing a technical outage on their end. They have not given an ETA on a resolution.
Posted Aug 05, 2024 - 15:00 CDT
Update
Our teams are still partnering with UPS to further investigate the issues that are preventing our merchants from processing UPS labels.
Posted Aug 05, 2024 - 10:56 CDT
Investigating
We are currently investigating this issue.
Posted Aug 05, 2024 - 10:26 CDT
This incident affected: ShippingEasy (app.shippingeasy.com, shippingeasy.com) and Carriers (UPS).