Phone Support
Incident Report for ShippingEasy
Resolved
We have been receiving reports that the phone issues have subsided.
Posted Mar 28, 2022 - 11:15 CDT
Identified
The issue has been identified and we will update you as soon as we have more information.
Posted Mar 28, 2022 - 10:30 CDT
Investigating
ShippingEasy Support is experiencing technical issues with our support phone lines.
The chat option is still available to contact us if immediate assistance is needed.

We are actively monitoring the status of these issues and will provide updates as they become available to us.
Thank you for your patience!
You can also check the status at https://status.zendesk.com/
Posted Mar 28, 2022 - 10:30 CDT
This incident affected: Support Services (Phone Support).