Tracking Number Link Issue

Incident Report for ShippingEasy

Resolved

Thank you for your patience while ShippingEasy Engineers worked to resolve your issues.
Please refresh your browser in order to reflect the changes made.
Posted Oct 04, 2022 - 08:26 CDT

Update

We are continuing to investigate this issue.
Posted Oct 03, 2022 - 16:26 CDT

Investigating

ShippingEasy engineers are aware of an issue impacting tracking number links and are actively investigating.
Posted Oct 03, 2022 - 12:12 CDT
This incident affected: Carriers (USPS, UPS, FedEx).