SCAN Form Issues
Incident Report for ShippingEasy
Resolved
SCAN Form issues have been resolved.
Posted Jan 19, 2022 - 12:30 CST
Monitoring
A SCAN Form fix has been implemented and we are closely monitoring the recovery of this functionality.
Posted Jan 19, 2022 - 12:21 CST
Investigating
ShippingEasy is aware of the technical issues impacting Stamps.com SCAN Forms. We are actively investigating these issues and will provide updates as they become available.
Thank you for your patience!
Posted Jan 19, 2022 - 11:53 CST
This incident affected: Carriers (USPS).